Inceptor won't connect

  1. Huawei p10 lite
  2. Ver 2.0.6
  3. I activated the inceptor with the qr on the box, but the inceptor won’t connect, the app only shows the inceptor logo flashing, I press quick play, says connecting and nothing happens. I tried restarting the Bluetooth, restarting the phone and reinstalling the app, no changes


I’m using a Samsung Galaxy S8. Getting the same issue here


one question to rule this out: did you guys charge the inceptors before trying to connect?


Hi, the lite version of Huawei has a Bluetooth problem with their driver. They accept very fast advertising but they can’t maintain such fast operating speed. We are preparing an app for this android that will update the firmware in order to let the Inceptor communicate with the smartphone with higher advertising time.

Eta is January, most of the app is ready. We’ll post the link here in the troubleshooting section


I activated 2 inceptores. one on a Xperia XZs , that one was working one day. second one acitvated on a Xperia Z2, thisone accepted the QRCode , but never connected.

Now both are not connecting.

V. 2.0.6
Android : 6.0.1(z2) and 8.0.0(XZs)


p9 lite with version 2.0.7 still no connection…first it says connected and then after few seconds it says disconnected again…
only got it connected to nexus 5x…but need 2 players :slight_smile:


scanned code and connected mine to iphone 6plus . after two or three failed attempts it finally connected only after i had device plugged in (it was already fully charged) . since then would not connect . i logged out and re logged in and asked to scan code but now code does not work. closed app and reopened , logged into my facebook as well this time (had only logged in via email after the log out) and now not prompted to scan but inceptor still will not connect . sent similar notice in discord chat hoping to get help soon.


this has now turned into the biggest nightmare… very upsetting. no longer sure the combination used to log in or what i had logged in when i first connected interceptor . have two and dont want to use up the other code . hoping developers provide new codes or find a way to remove/ reinitialize accounts .


@vivaporu, contact - we’ll provide a new one. Say you talk with Francesco in the forum.


For the bluetooth connection problem, we are close to launch a patch. Will create a sticky post here in the Bug and Troubleshooting section


update since i purchased an new phone (moved from iphone 6plus to iphone 8) i logged in via facebook (thats another story) and the device is now attaching with no problem although when game is about to start it crashes /or stops and says needs another player with attachment to play. i dont know if this is common. but thought i would share . thank for fast response .


Heya. If you’re doing a team deathmatch or elimination you need another inceptor around to do it. Headshot is solo though.


cool to officially know, finally tested it out with a coworker , i won LOL .


I am having the same issue of the interceptor connecting and disconnecting seconds later. I have an iphone 8plus.


This is a bug I’ve seen and noticed personally. A few things to check:

  1. Bluetooth status. Restart your phone and try again.
  2. Battery strength: Check both your phone’s battery and the battery of the inceptor.
  3. Distance: Make sure the inceptor is as close to the phone as possible.

These are the main things. If it’s not one of these, you may want to submit a support ticket.


I have also noticed if there is another inceptor within 12" or so, the connection doesn’t always work. Move away about 4’ and it usually connects.


Hi there,
Huawei P10, last Google Play version.
In my first pairing with inceptor, I shot to QRCode in the box, and it succesfully connected.
Then I logged out. Next time I started, it request me the QRCode again, shot again qrcode in the box, but now I always get “Inalid QRCode”… No more chances to reconnect again.
I tried several times. I even deleted app cache+data, uninstalled and installed again, but with no luck.
Please help.
Tnx in advance.


Having the same issue on my Samsung S5 since the latest software update, up till the update the inceptor was connecting fine and the app had no issues. the drone fight also crashes the phone after about 2 minutes


Send a direct email to the game developer, perhaps they could terminate your account and provide you with a new QR code to start over with?? Lots of people here have this issue…


And please can you provide a link/e-mail to me, for reporting problem to
who should support me? Thank you.