I'm not able to sign-up to Father.IO


I’m not able to sign-up to the father.io beta… After the tutorial for the tactical map completes and the sign-up window pops up I’m not able to sign-up via email and Facebook… It just loads and comes back to the screen… A similar issue is happening to another one of my friends while the rest are using the app completely fine. Even promo codes aren’t working… Any suggestions and help?

Additional info: My mobile is a Huawei Y5-2 Android 5.0.1


Hi @Ali-Tair sorry to hear you’re having issues. Have you tried clearing your app cache and reinstalling the game?


I did twice to no avail


Hey @Ali-Tair. A lot of players have had problems logging into the game via Facebook, so the primary way is to register with an email and password. If at all possible, could you take screenshots, or screen record, the next time you attempt to log in. This may help us better help you :sunglasses:

But just as @Kaj recommended, reinstalling the game and attempting the log in would be your best option.


I’m on iOS 10.2.1 and I have the same issue. It stops when it gets to the point on the informational demo where it shows the bus icon and your supposed to click on othe of the 3 buttons that show after clicking the bus, will the button in red does nothing.


Let me clarify. I had been a while since I opened the game cause it doesn’t work… for me. On the tutorial, then you get to the poi that is a bus, you can’t click the red button that say harvest. So I thought maybe it’s cause of my location. I seen some vids of ppl playing it in Canada so I put on a VPN to Canada and it still didn’t work. Can ppl in the USA play this demo?


I’m on redmi note 3 Lineage OS and i have the same issue. I’ve re installed the app thrice and tried clearing the cache too. Just doesn’t work.