General Account Issues


A quick look around the forum and my own experience trying to test out 2 Inceptor devices (one for myself and one for my friend) revealed some teething problems with the accounts.

  1. Unable to recover the account used in the Tactical Map.
  • Forget password doesn’t help.
  • Signing up with the email that may have been used in Tactical Map (I can’t remember the email used) is blocked by the fact that the Inceptor won’t connect as it was already activated when I signed up using Facebook.
  1. Unable to choose username when signing up with Facebook.
  • Self-explanatory.
  1. Facebook account appears to override Father IO account.
  • I tried one of the method mentioned by another forum user about quitting the sign-up process half-way (before choosing username) in an attempt to get back the username and resources acquired in the Tactical Map app, but end up not only I cannot choose my username, I can only connect with my Inceptor when I sign in to my Facebook account, which makes my username appear as the one used in the first account created when I signed up via Facebook.

Here’s what I did:

  1. Install Father IO AR FPS app on phone
  2. Tried to “forget password” for all my possible game accounts; failed to recover any account.
  3. Selected “Login with Facebook” (not sign-up with Facebook).
  4. Account created and logged in.
  5. Activated Inceptor 1 on this account.
  6. Install Father IO AR FPS app on phone 2.
  7. Create a standard Father IO account on phone 2. Did not link to Facebook.
  8. Activated Inceptor 2 on phone 2.
  9. Tested quick match with each other to verify Inceptor functionality.
  10. Noticed that the username of the account on phone 1 is user_###### (not actual username)
  11. Sign out from phone 1.
  12. Checked forums and discovered something about getting back old Tactical Map account.
  13. Tried to create a new account on Phone 1, but stop short of choosing a username.
  14. Verified my account in that email used for the new account.
  15. Restarted the app and logged in with that new account. Can’t connect to Inceptor because QR code is “invalid”.
  16. Go to Settings menu in Phone 1, click Facebook Connect.
  17. Connected. Able to connect to Inceptor 1 as well.
  18. Launched a quick indoor deathmatch.
  19. Discovered that my username for the new account is still following that of the account first created through Facebook, which because I have no way to choose it, is just “user_######”.
  20. Repeated the creation of new accounts with proper usernames and then connecting FB to it, same thing, same username of “user_######”.

So, effectively, the first Inceptor is stuck to a Father IO account created by “logging” in to Facebook which the process failed to ask me for a username. My Inceptor 1 is doomed to user_######, while Inceptor 2 is tied to my test account instead of my friend’s.

I think sorting out of user account and username should be the highest priority now, and the tying of Inceptor to accounts, so that players can properly get a hold of their accounts.

I understand some players want to get back their accounts from Tactical Map period, but the transfer is so obscure, you might as well just wipe everything and start over. The map is out of commission anyway. Keep the map, purge the accounts, let everyone start afresh, de-link all the Inceptors, and provide a master control panel either in-game or in a web interface to manage the Inceptors and accounts.

Account management is a top priority for any kind of digital service, before even the physical products are being delivered to customers.


ok similar case my own
I am a Backer as well. I received a wakeup call email saying my inceptores were on the way : stuck_out_tongue:
So I have another phone… and the tactical map was left on my old dead S5 with some nice areas.
I went to GOOGLE play and instaled the game on the new phone.

  • was nicely surprised NOT TO SEE the tactical map but THE GAME.
    -Asked me for the eMail and pass… now the problem starts.
    -went to email looking for passwords or logins…but just found a mail from father io to confirm my email, did so. confirmed it.
  • Tried the FORGET PASSWORD - it keeps saying after the passwords " Invalid or expired action code. Try again." hmmm … I used 1 CAP + 2 symbols + 8 letters + 2 Numbers.
    I tried the reset password step like 3-4 times… but no chance.
    Thank you for your attention to this matter.