Can't Create Game Account


Tried creating an account in-game by using the e-mail and Facebook methods, neiter worked. Also tried logging in after creating an account here… for poops and giggles… it wasn’t funny, but I had to go anyways.

Tried with e-mail yesterday and today… also looked through my e-mail folders both days and found nothing.

I linked my Facebook successfully and when I try to login with it I’m prompted that I’ve already authorized Facebook. After the prompt leaves I receive another prompt saying I’ve entered the wrong email. Beats me.

Any ideas/fixes for this?

PS. I already looked in forum for this paticular issue.


@tarun @IamYourVirtualFather @Kaj


I don’t see anything in your reply, not sure if there’s supposed to be something or not.


No. I was tagging people who could possibly help with the issue.


Hey @Mr_REE,

You may have to try a few times. The last time the game was update, I think about a month ago, I had to register all over again after downloading the beta (on iOS). I decided to try and register a new email, and after a few attempts it worked. It seemed like the game crashed a few times, but the account was made. I didn’t receive a confirmation email though.

I hope this helps. :sunglasses:


Having the exact same issue (three months after this original post), any true fix? Have tried multiple times.


Hey @Infuego3, I’m sorry to say there is no real fix right now. Not until full release hits. And the full release is right around the corner. ^^


Thank you for the reply.